MikroTik RouterOS 自动备份配置并邮件发送到指定邮箱脚本

peng RouterOS评论166阅读模式

MikroTik RouterOS系统备份功能默认都是加密的,既对文件内容进行了加密,也对文件进行了加密,当我们需要将当前设备的配置刷写到另外的设备时,可能会因为硬件参数不一样,而无法对脚本内容进行修改,今天就给爱好者们介绍明文导出配置并邮件发送到指定邮箱的脚本。MikroTik RouterOS 自动备份配置并邮件发送到指定邮箱脚本-图片1

:local SMTPServer "smtp.163.com"
:local SMTPPort "465"
:local SendEmailTo "收件人邮箱"
:local Sender "发件人邮箱"
:local pwd "发件人邮箱的key"
:local Themes "RouteOS-Backup-"
:local SMTPIP [:resolve $SMTPServer]
/tool e-mail set server=$SMTPIP port=$SMTPPort tls=yes from=$Sender user=$Sender password=$pwd
:local date [/system clock get date]
/export file=($Themes.$date.".rsc")
:delay
/tool e-mail send to=$SendEmailTo tls=yes from=$Sender subject=("RouteOS备份") body=("$Themes$date") file=($Themes.$date.".rsc")
:delay
/file remove ($Themes.$date.".rsc")

备份效果展示

MikroTik RouterOS 自动备份配置并邮件发送到指定邮箱脚本-图片2

文章末尾固定信息

weinxin
我的微信
我的微信
微信扫一扫
 
peng
  • 本文由 peng 发表于 2024年2月15日00:27:06
  • 转载请务必保留本文链接:https://www.ixmu.net/68.html
  • ROS备份
  • 配置导出
  • 自动备份
匿名

发表评论

匿名网友
:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:
确定

拖动滑块以完成验证