RouterOS Quenu List 优化流量优先级

peng RouterOS评论330阅读模式

routeros的qos功能设置上比较专业,没有大家熟悉的“游戏模式”、“网页模式”等一键配置,routeros的qos功能需要再Quenu选项下配置,下面这个配置可参考配置。

RouterOS Quenu List 优化流量优先级

iptables添加封装标记

流量顺序 ping>dns>0-512小包>UDP>网页,防火墙要关闭fasttrack快速通道才能生效。

/ip firewall mangle
add action=mark-packet chain=forward comment="Mark Ping" new-packet-mark=PING passthrough=no protocol=icmp
add action=mark-packet chain=forward comment="Mark DNS Query" new-packet-mark=DNS_P passthrough=no port=53 protocol=udp
add action=mark-connection chain=forward comment="Mark MiniPackets Down" dst-address=10.0.0.0/24 new-connection-mark=MiniCDown packet-size=0-512 passthrough=yes
add action=mark-packet chain=forward connection-mark=MiniCDown new-packet-mark=MiniPDown passthrough=no
add action=mark-connection chain=forward comment="Mark MiniPackets Up" new-connection-mark=MiniCUp packet-size=0-512 passthrough=yes src-address=10.0.0.0/24
add action=mark-packet chain=forward connection-mark=MiniCUp new-packet-mark=MiniPUp passthrough=no
add action=mark-connection chain=forward comment="Mark UDP GAME" new-connection-mark=UDPC protocol=udp passthrough=yes
add action=mark-packet chain=forward connection-mark=UDPC new-packet-mark=UDPP passthrough=no
add action=mark-connection chain=forward comment="Mark Web Traffic" new-connection-mark=WebC passthrough=yes port=80,443 protocol=tcp
add action=mark-connection chain=forward new-connection-mark=WebC passthrough=yes port=80,443 protocol=udp
add action=mark-packet chain=forward connection-mark=WebC new-packet-mark=WebP passthrough=no

Quenu数据队列

通过防火墙为流量添加封装标记,Quenu Tree利用封装标记对流量进行优先级优化

/queue tree
add name=A parent=global
add name=a-PingFirst packet-mark=PING parent=A priority=1 queue=default-small
add name=b-DNS packet-mark=DNS_P parent=A priority=1 queue=default-small
add name=B parent=global
add name=a-MiniPDownFirst packet-mark=MiniPDown parent=B priority=2 queue=default-small
add name=b-MiniPUpFirst packet-mark=MiniPUp parent=B priority=2 queue=default-small
add name=C parent=global
add name=a-GAME packet-mark=UDPP parent=C priority=3 queue=default
add name=b-Web packet-mark=WebP parent=C priority=3 queue=pcq-download-default

 

文章末尾固定信息

weinxin
我的微信
我的微信
微信扫一扫
peng
  • 本文由 peng 发表于 2023年8月6日08:56:26
  • 转载请务必保留本文链接:https://www.ixmu.net/44.html
匿名

发表评论

匿名网友
:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:
确定

拖动滑块以完成验证