使用萌咖华为云解析为RouterOS配置ipv4 & ipv6 DDNS脚本

渡鸦 MikroTik评论93阅读模式

自己使用的是移动宽带上行1000M下行50M,日常使用完全没有问题,但是想偶尔在外面访问群晖上面的视频和文件,没有公网ipv4地址就比较难受了,大佬们给JinPeng提了个意见,可以基于ipv6 Wireguard搭建一个vpn来进行访问,至于没有ipv6网络的环境,可以使用手机连接ipv6 wireguard,然后通过数据线共享手机网络给电脑使用。

家庭宽带虽然分配了公网ipv6地址,但却不是固定的,需要配合ddns进行使用,JinPeng一直在使用萌咖的华为云解析api,这里也继续使用它,写个简单的脚步继续动态dns脚本。

使用萌咖华为云解析为RouterOS配置ipv4 & ipv6 DDNS脚本

这里脚本没有那么多的校验过程,直接是简单粗暴的方式,通过6.ipw.cn获取公网ipv6地址,使用萌咖V佬的华为云解析api进行dns记录定时更新,从而实现动态DNS。

ipv6 ddns脚本

:local huaweicloudkey "XXXX"
:local huaweicloudsecret "XXXX"
:local domainname "ixmu.net"
:local hostname "gz-cm-ros"
:local type "AAAA"
:local dateResult [/tool fetch url="http://6.ipw.cn" output=user as-value]
:local date ($dateResult->"data")
/tool fetch url=("https://api.moeclub.org/HWDNS/?key=". $huaweicloudkey . "&secret=" . $huaweicloudsecret . "&action=add&target=record&domain=" . $domainname . "&name=" . $hostname ."&type=" . $type . "&ttl=15&data=" . $date ) output=usery

既然ipv6 ddns脚本都有了,还这么简单粗暴,直接改改就是ipv4 ddns脚本了

:local huaweicloudkey "XXXX"
:local huaweicloudsecret "XXXX"
:local domainname "ixmu.net"
:local hostname "gz-cm-ros"
:local type "A"
:local dateResult [/tool fetch url="http://4.ipw.cn" output=user as-value]
:local date ($dateResult->"data")
/tool fetch url=("https://api.moeclub.org/HWDNS/?key=". $huaweicloudkey . "&secret=" . $huaweicloudsecret . "&action=add&target=record&domain=" . $domainname . "&name=" . $hostname ."&type=" . $type . "&ttl=15&data=" . $date ) output=user


文章末尾固定信息

weinxin
我的微信
我的微信
微信扫一扫
 
渡鸦
  • 本文由 渡鸦 发表于 2024年6月2日21:03:48
  • 转载请务必保留本文链接:https://www.ixmu.net/121.html
匿名

发表评论

匿名网友
:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:
确定

拖动滑块以完成验证