RouterOS定时更新运营商ip列表脚本

渡鸦 MikroTik评论450阅读模式

MikroTik RouterOS在进行多线接入的情况下,需要根据目标ip进行出口分流,这时我们就需要用到各isp的ip列表了,这里我们采用Metro梳理的ip列表了。

RouterOS定时更新运营商ip列表脚本

Metro梳理的运营商ip列表基于bgp网络收集,相对于APNIC数据更加准确。Metro提供了电信,联通 移动/铁通,教育网,其他等几个路由表,路由列表每天更新,以路由表格式table地址列表格式list两种方式提供各运营商ip信息。

以下脚本可运用定时自动更新ip列表,这里以电信作为展示,其他的类似

:local date
:set date [system/clock/get date]
:local Y
:set Y [:pick $date 0 4]
:local M
:set M [:pick $date 5 7]
:local D
:set D [:pick $date 8 10]
:set D ($D - 1)
/tool fetch url="http://www.tcp5.com/list/$Y.$M/telecom$Y-$M-$D-12.rsc"
/system logging disable 0
/ip firewall address-list
remove [find list=List_ChinaTelecom]
/import "telecom$Y-$M-$D-12.rsc"
/system logging enable 0
:local ChinaTelecom [:len [/ip firewall address-list find list="List_ChinaTelecom"]]
/file remove [find name="telecom$Y-$M-$D-12.rsc"]
:log info ("Telecom列表更新:"."$ChinaTelecom"."条规则")

文章末尾固定信息

weinxin
我的微信
我的微信
微信扫一扫
 
渡鸦
  • 本文由 渡鸦 发表于 2024年1月24日23:49:33
  • 转载请务必保留本文链接:https://www.ixmu.net/63.html
匿名

发表评论

匿名网友
:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:
确定

拖动滑块以完成验证